$re = '/access_token=(.*?)&expires=\d+/';
$str = 'access_token=CAABletmsJHgBAEMfdJEgA1wEXgqwVgfM1nrTgyHq9XxkIEvLVGOUMq80ZBaA2ZA6Ndc18xNwZAJCDwpILNSKgGiVu4SIm9B0K5ocv7ZCVFV1bxKrNW9qrIqK1HKIz3uD6nO4RQnVgfVmLggoqZCVkPwjEY79ijZC0SYKPYM2RN9qg4TZB5E2iMz5WfAAACddAbXaEZCbzkBSoSZBTlEyea8rC&expires=5181509';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);