const regex = /(?:^[0-9A-Za-z]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^[0-9A-Za-z]+)', 'gm')
const str = `3345 Michelson Drive, Suite 400, Irvine, CA 92612
12303 Airport Way, Suite 250, Broomfield, CO 80021
Two North Riverside Plaza, Suite 1430, Chicago, IL 60606
#twentytwo Northumberland Drive, Apostrophe 55, Moon, MN 13145
!Variety Coffe Cup, Potraiture 247, Mars, MS 88888
.* Everywhere, Nowhere 123, Eternity, ET 12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}