import re
regex = re.compile(r"(?:^[0-9A-Za-z]+)", flags=re.MULTILINE)
test_str = ("3345 Michelson Drive, Suite 400, Irvine, CA 92612\n"
"12303 Airport Way, Suite 250, Broomfield, CO 80021\n"
"Two North Riverside Plaza, Suite 1430, Chicago, IL 60606\n"
"#twentytwo Northumberland Drive, Apostrophe 55, Moon, MN 13145\n"
"!Variety Coffe Cup, Potraiture 247, Mars, MS 88888\n"
".* Everywhere, Nowhere 123, Eternity, ET 12345")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")