using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"domain/path/\?[^/\n]*(?:/specificHash)?$";
string input = @"domain/path/?anything
--> YES
domain/path/?anything#/specificHash
--> YES
domain/path/?anything#/otherHash
--> NO";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}