$re = '~domain/path/\?[^/\n]*(?:/specificHash)?$~m';
$str = 'domain/path/?anything
--> YES
domain/path/?anything#/specificHash
--> YES
domain/path/?anything#/otherHash
--> NO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);