package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^;"\\]+(?:"(?:[^"\\]*(?:\\.[^"\\]*)*)"[^";\\]*)*`)
var str = `my.parameter 10; the.foo "Procedural Map"; pve; server.description "This; is \"my\", my description,.\n"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}