re = /[^;"\\]+(?:"(?:[^"\\]*(?:\\.[^"\\]*)*)"[^";\\]*)*/m
str = 'my.parameter 10; the.foo "Procedural Map"; pve; server.description "This; is \\"my\\", my description,.\\n"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end