using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*^(?=.{8,20})(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9]).*$";
string input = @"adeffk3535
Abjdf83894";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}