import Foundation
let pattern = #"^[{]?[0-9a-fA-F]{8}[-]?([0-9a-fA-F]{4}[-]?){3}[0-9a-fA-F]{12}[}]?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
8be94c81-a218-42f5-bf1b-383f15490d42
0C885DD3-7DD9-484B-9B20-3E6552BCA144
{0C885DD3-7DD9-484B-9B20-3E6552BCA144}
0C885DD37DD9484B9B203E6552BCA144
{0C885DD3-7DD9-484B-9B20-1E6552BCA144}
0C885DD3-7DD9484B9B203E6552BCA144
0C885DD37DD9484B9B203E6552BCA14
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)