const regex = /^9903(?=[0-9]{16}$)0*([0-9]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^9903(?=[0-9]{16}$)0*([0-9]+)$', 'gm')
const str = `99030000000000000001
99030000000000000011
99030000000000000111
99030000000000001111
99031111111111111111
990311111111111111
99030000000000000000
99030000000000000011
99030000100000000111
95030000000000001111
99031111111111111111
990311111111111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}