$re = '/^9903(?=[0-9]{16}$)0*([0-9]+)$/m';
$str = '99030000000000000001
99030000000000000011
99030000000000000111
99030000000000001111
99031111111111111111
990311111111111111
99030000000000000000
99030000000000000011
99030000100000000111
95030000000000001111
99031111111111111111
990311111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);