import re
regex = re.compile(r"(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}) - - \[(\d{2}\/[a-zA-Z]{3}\/\d{4}:\d{2}:\d{2}:\d{2} (\+|\-)\d{4})\] ((\"(GET|POST|HEAD|OPTIONS) )(.+)(HTTP\/1\.(1|0)\")) (\d{3}) (\d+) ([\"]((\-)|(.+))[\"]) ([\"](.+)[\"])")
test_str = ("127.0.0.1 - - [19/Jan/2016:15:27:37 +0200] \"GET / HTTP/1.1\" 304 0 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"\n"
"127.0.0.1 - - [19/Jan/2016:15:27:37 +0200] \"GET / HTTP/1.1\" 304 0 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"\n"
"127.0.0.1 - - [19/Jan/2016:15:27:40 +0200] \"GET /asd HTTP/1.1\" 404 570 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"\n"
"127.0.0.1 - - [19/Jan/2016:15:27:44 +0200] \"GET /asd HTTP/1.1\" 404 570 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"\n"
"127.0.0.1 - - [19/Jan/2016:15:27:45 +0200] \"GET /asd HTTP/1.1\" 404 570 \"-\" \"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.111 Safari/537.36\"")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")