using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+%";
string input = @"43-20If you can find a way through the river of magma, I calculate a 60% chance you will arrive at one of the sources of sacred power. 100%.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}