$re = '/\d+%/';
$str = '43-20If you can find a way through the river of magma, I calculate a 60% chance you will arrive at one of the sources of sacred power. 100%.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);