const regex = /<[^>]+>(*SKIP)(*FAIL)|([\w']+(?:[\w'-]*))/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]+>(*SKIP)(*FAIL)|([\\w\']+(?:[\\w\'-]*))', 'gu')
const str = `Non ! Non ! Je ne veux pas d'un éléphant dans un boa.<br>
<p> Un boa c'est très dangereux, et un éléphant élévé c'est très encombrant. Chez moi c'est tout petit. J'ai besoin d'un mouton. Dessine-moi un mouton.
</p>
-Laisse-moi dire mouton...
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}