using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?=\sis)|(?<=is\s)\d+?$";
string input = @"Time: 02:30 PM Your OTP is 3242.
12345 is your OTP. TIME: 04:45 AM.
Your otp for account 123456789 is 4565";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}