const regex = /^\d+(?=\sis)|(?<=is\s)\d+?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(?=\\sis)|(?<=is\\s)\\d+?$', 'gm')
const str = `Time: 02:30 PM Your OTP is 3242.
12345 is your OTP. TIME: 04:45 AM.
Your otp for account 123456789 is 4565`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}