using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div.+?>(.+)?<\/div>";
string substitution = @" gdgf";
string input = @"<h3>Programma en uitslagen</h3>
<table width=""100%"">
<tr>
<th>ronde</th>
<th>dag</th>
<th>datum</th>
<th></th>
<th>thuis</th>
<th>uit</th>
<th> </th>
<th colspan=""1""> </th>
<th colspan=""2"">uitslag</th>
<th>ct</th>
<th>cu</th>
<th> </th>
</tr>
<tr>
<td class=""getal"">1</td>
<td>Ma.</td>
<td>22-08-2016 19:30</td>
<td>
<div title=""Add to Calendar"" class=""addthisevent"">
<span class=""start"">22/08/2016 19:30:00</span>
<span class=""end"">22/08/2016 22:30:00</span>
<span class=""timezone"">Europe/Amsterdam</span>
<span class=""title"">Kamperduin 1 vs Kamperduin 2</span>
<span class=""description"">Biljartwedstrijd 3Bnd B1 - Ronde 1</span>
<span class=""location""></span>
<span class=""organizer"">KNBB</span>
<span class=""organizer_email""></span>
<span class=""all_day_event"">false</span>
<span class=""date_format"">DD/MM/YYYY</span>
<span class=""alarm_reminder"">60</span>
</div>
</td>
<td><a href=""http://www.biljartpoint.nl/index.php?page=teamdetail&team_id=29629&compid=2470&poule=A&district=57"">Kamperduin 1</a></td>
<td><a href=""http://www.biljartpoint.nl/index.php?page=teamdetail&team_id=29627&compid=2470&poule=A&district=57"">Kamperduin 2</a></td>
<td></td>
<td> </td>
<td></td>
<td> </td>
<td> </td>
<td> </td>
<td> </td>
</tr>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}