import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div.+?>(.+)?<\\/div>";
final String string = "<h3>Programma en uitslagen</h3>\n"
+ " <table width=\"100%\">\n"
+ " <tr>\n"
+ " <th>ronde</th>\n"
+ " <th>dag</th>\n"
+ " <th>datum</th>\n"
+ " <th></th>\n"
+ " <th>thuis</th>\n"
+ " <th>uit</th>\n"
+ " \n"
+ " <th> </th>\n"
+ " <th colspan=\"1\"> </th>\n"
+ " <th colspan=\"2\">uitslag</th>\n"
+ " <th>ct</th>\n"
+ " <th>cu</th>\n"
+ " <th> </th>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td class=\"getal\">1</td>\n"
+ " <td>Ma.</td>\n"
+ " <td>22-08-2016 19:30</td>\n"
+ " <td>\n"
+ " <div title=\"Add to Calendar\" class=\"addthisevent\">\n"
+ " <span class=\"start\">22/08/2016 19:30:00</span>\n"
+ " <span class=\"end\">22/08/2016 22:30:00</span>\n"
+ " <span class=\"timezone\">Europe/Amsterdam</span>\n"
+ " <span class=\"title\">Kamperduin 1 vs Kamperduin 2</span>\n"
+ " <span class=\"description\">Biljartwedstrijd 3Bnd B1 - Ronde 1</span>\n"
+ " <span class=\"location\"></span>\n"
+ " <span class=\"organizer\">KNBB</span>\n"
+ " <span class=\"organizer_email\"></span>\n"
+ " <span class=\"all_day_event\">false</span>\n"
+ " <span class=\"date_format\">DD/MM/YYYY</span>\n"
+ " <span class=\"alarm_reminder\">60</span>\n"
+ " </div>\n"
+ " \n"
+ " </td>\n"
+ " <td><a href=\"http://www.biljartpoint.nl/index.php?page=teamdetail&team_id=29629&compid=2470&poule=A&district=57\">Kamperduin 1</a></td>\n"
+ " <td><a href=\"http://www.biljartpoint.nl/index.php?page=teamdetail&team_id=29627&compid=2470&poule=A&district=57\">Kamperduin 2</a></td>\n"
+ " <td></td>\n"
+ " <td> </td>\n"
+ " <td></td>\n"
+ " <td> </td>\n"
+ " <td> </td>\n"
+ " <td> </td>\n"
+ " <td> </td>\n"
+ " </tr>";
final String subst = " gdgf";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}