using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a[^<>]href=""\${.*?}"".*?>.*?<\/a>)";
string input = @"<a href=""/foo"">foo</a> some sample text <a href=""${bar}"">bar</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}