$re = '/(<a[^<>]href="\${.*?}".*?>.*?<\/a>)/';
$str = '<a href="/foo">foo</a> some sample text <a href="${bar}">bar</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);