import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<user>)\\w+(?=<\\/user>)";
final String string = "random data\n"
+ "<user>test1</user>\n"
+ "some more random data\n\n"
+ "not needed\n"
+ "<user>test2</user>\n"
+ "etc etc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}