$re = '/(?<=<user>)\w+(?=<\/user>)/';
$str = 'random data
<user>test1</user>
some more random data
not needed
<user>test2</user>
etc etc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);