const regex = /(?=(?:\d|(?<=\d)[\W]\d){4,5})\d|(?<=(?<!^)\G)\d|(?<=\d)[\W]\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(?:\\d|(?<=\\d)[\\W]\\d){4,5})\\d|(?<=(?<!^)\\G)\\d|(?<=\\d)[\\W]\\d', 'gm')
const str = `any text 000 00 more texts" will become "any text ***** more texts"..notice that the space is removed
"any text 000 00 more texts 00" will become "any text ***** more texts 00"
"any text 000 00 more texts 00 00" will become "any text ***** more texts ****"
"any text 00-00 more texts 00_00" will become "any text **** more texts ****"`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);