import re
regex = re.compile(r"(?=(?:\d|(?<=\d)[\W]\d){4,5})\d|(?<=(?<!^)\G)\d|(?<=\d)[\W]\d", flags=re.MULTILINE)
test_str = ("any text 000 00 more texts\" will become \"any text ***** more texts\"..notice that the space is removed\n\n"
"\"any text 000 00 more texts 00\" will become \"any text ***** more texts 00\"\n\n"
"\"any text 000 00 more texts 00 00\" will become \"any text ***** more texts ****\"\n"
"\"any text 00-00 more texts 00_00\" will become \"any text **** more texts ****\"")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)