$re = '/\[(.*?)\]\s*\[/';
$str = '[ul] [li]List Item 1[/li] [li]List Item 2[/li] [/ul]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);