re = /\[(.*?)\]\s*\[/
str = '[ul] [li]List Item 1[/li] [li]List Item 2[/li] [/ul]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end