const regex = /(![^\S\r\n]*)(\w+(?:[^\S\r\n]+\w+)*)([^\S\r\n]*!)(?=(?:[^!\r\n]*![^!\r\n]*!)*[^!\r\n]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(![^\\S\\r\\n]*)(\\w+(?:[^\\S\\r\\n]+\\w+)*)([^\\S\\r\\n]*!)(?=(?:[^!\\r\\n]*![^!\\r\\n]*!)*[^!\\r\\n]*$)', 'gm')
const str = `this! i!s the i!npu!t
a!a!bb! c!c
a!b!c!d!e!f
!r!
! !
this! i!s the i!npu!t
this! ! is the i!npu!t
this! i i !s the i!npu!t`;
const subst = `<b>$1</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);