$re = '/(![^\S\r\n]*)(\w+(?:[^\S\r\n]+\w+)*)([^\S\r\n]*!)(?=(?:[^!\r\n]*![^!\r\n]*!)*[^!\r\n]*$)/m';
$str = 'this! i!s the i!npu!t
a!a!bb! c!c
a!b!c!d!e!f
!r!
! !
this! i!s the i!npu!t
this! ! is the i!npu!t
this! i i !s the i!npu!t';
$subst = "<b>$1</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;