using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^L(\d),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+)$";
string input = @"L1,3,5,0,5,80,40,31,0,0,0,0,512,412,213,900";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}