re = /^L(\d),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+),(\d+)$/
str = 'L1,3,5,0,5,80,40,31,0,0,0,0,512,412,213,900'
# Print the match result
str.match(re) do |match|
puts match.to_s
end