$re = '/^(?=.*\b(apple)\b)(?=.*\b(orange)\b)(?=.*\b(plum)\b)/m';
$str = 'apple orange plum pear cherry';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);