re = /^(?=.*\b(apple)\b)(?=.*\b(orange)\b)(?=.*\b(plum)\b)/m
str = 'apple orange plum pear cherry'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end