#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)_.*\n*(.*)\n*(.*)\n*(.*)\n*(.*)"
Local $sString = "والخاتِم بكسر التاء اسم فاعل، فكأنه قد جاء آخر الرسل، والخاتَم بفتح التاء اسم آلة، كأنه قد ختمت به الرسالة." & @CRLF & _
"__________" & @CRLF & _
"" & @CRLF & _
"(1) - سورة الأحزاب آية : 43." & @CRLF & _
"(2) - سورة البقرة آية : 157." & @CRLF & _
"(3) - سورة الأنعام آية : 17." & @CRLF & _
"(4) - سورة الكهف آية : 19."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")