re = /_.*\n*(.*)\n*(.*)\n*(.*)\n*(.*)/m
str = 'والخاتِم بكسر التاء اسم فاعل، فكأنه قد جاء آخر الرسل، والخاتَم بفتح التاء اسم آلة، كأنه قد ختمت به الرسالة.
__________
(1) - سورة الأحزاب آية : 43.
(2) - سورة البقرة آية : 157.
(3) - سورة الأنعام آية : 17.
(4) - سورة الكهف آية : 19.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end