$re = '/^.*(\S)(?: ?\1){9,}.*$/m';
$str = 'this a tesssssssssst
this a tess sss ssssst';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);