re = /^.*(\S)(?: ?\1){9,}.*$/m
str = 'this a tesssssssssst
this a tess sss ssssst'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end