import re
regex = re.compile(r"(?!$)[123]{0,1}\d(\.\d{1,2})(?!(\s){0,3}%)", flags=re.MULTILINE)
test_str = ("14.2\n"
"1.5\n"
"1002\n"
"4.3\n"
"6.3%\n"
"32.1 %\n"
"$100")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")