re = /CC\K[a-zA-Z0-9]+(?=DD)/
str = 'CCdatadfhdfghata1DD
CC3DD
CCdatazxczxczxczxdata3DD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end