const regex = /\d{2}-(January|February|March|April|May|June|July|August|September|October|November|December)-\d{4}/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{2}-(January|February|March|April|May|June|July|August|September|October|November|December)-\\d{4}', 'i')
const str = `fdsfdf04-February-2016 fdfs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}