import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "age [0-9]*.\\n(.*)";
final String string = "Born Elon Reeve Musk\n"
+ "June 28, 1971 (age 50)\n"
+ "Pretoria, Transvaal, South Africa\n"
+ "Citizenship \n"
+ "South Africa (1971–present)\n"
+ "Canada (1971–present)\n"
+ "United States (2002–present)\n"
+ "Education University of Pennsylvania (BS, BA)\n"
+ "Title \n"
+ "Founder, CEO and Chief Engineer of SpaceX\n"
+ "CEO and product architect of Tesla, Inc.\n"
+ "Founder of The Boring Company and X.com (now part of PayPal)\n"
+ "Co-founder of Neuralink, OpenAI, and Zip2\n"
+ "Spouse(s) \n"
+ "Justine Wilson\n"
+ "\n"
+ "(m. 2000; div. 2008)\n"
+ "Talulah Riley\n"
+ "\n"
+ "(m. 2010; div. 2012)\n"
+ "\n"
+ "(m. 2013; div. 2016)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}