import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s*?(\\+|-|\\*|\\/)\\s*(\\d+)(\\s*?(\\+|-|\\*|\\/)\\s*(\\d+))*";
final String string = "3+2*2\n"
+ "23+3/32\n"
+ " 3/2 \n"
+ " 3+5 / 2 \n"
+ " 3+5 / 32*50 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}