re = /(\d+)\s*?(\+|-|\*|\/)\s*(\d+)(\s*?(\+|-|\*|\/)\s*(\d+))*/m
str = '3+2*2
23+3/32
3/2
3+5 / 2
3+5 / 32*50 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end