// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Hi.*Page (\d+).*\n(.*)").unwrap();
let string = "Notes and highlights for
Outlive
Attia MD, Peter
Part I
Highlight (yellow) - Chapter 1: The Long Game: From Fast Death to Slow Death > Page 10 · Location 150
In 1900 , life expectancy hovered somewhere south of age fifty , and most people were likely to die from “ fast ” causes : accidents , injuries , and infectious diseases of various kinds . Since then , slow death has supplanted fast death . The majority of people reading this book can expect to die somewhere in their seventies or eighties , give or take , and almost all from “ slow ” causes .
Highlight (yellow) - Chapter 1: The Long Game: From Fast Death to Slow Death > Page 10 · Location 154
Four Horsemen : heart disease , cancer , neurodegenerative disease , or type 2 diabetes and related metabolic dysfunction .
Highlight (yellow) - Chapter 1: The Long Game: From Fast Death to Slow Death > Page 10 · Location 155
we must understand and confront these causes of slow death .
Highlight (yellow) - Chapter 1: The Long Game: From Fast Death to Slow Death > Page 10 · Location 158
Healthspan is typically defined as the period of life when we are free from disability or disease ,
Highlight (yellow) - Chapter 1: The Long Game: From Fast Death to Slow Death > Page 14 · Location 215
It is absurd and harmful to treat this disease like a cold or a broken bone , where you either have it or you don’t ; it’s not binary .
Highlight (yellow) - Chapter 1: The Long Game: From Fast Death to Slow Death > Page 14 · Location 218
Changing that mindset must be our first step in attacking slow death . We want to delay or prevent these conditions so that we can live longer without disease , rather than lingering with disease .
Highlight (yellow) - Chapter 1: The Long Game: From Fast Death to Slow Death > Page 17 · Location 270
Exercise is by far the most potent longevity “ drug . ” No other intervention does nearly as much to prolong our lifespan and preserve our cognitive and physical function .";
let substitution = "> $2 [@attia:2023 p.$1]\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}