#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{1,50}$)[a-z\d]+(?:[._-][a-z\d]+)*$"
Local $sString = "a" & @CRLF & _
"ab" & @CRLF & _
"foo" & @CRLF & _
"foo_123_bar" & @CRLF & _
"123foobarbaz123foobarbaz123foobarbaz123foobarbaz1" & @CRLF & _
"123foobarbaz123foobarbaz123foobarbaz123foobarbaz12" & @CRLF & _
"123foobarbaz123foobarbaz123foobarbaz123foobarbaz123" & @CRLF & _
"foo_bar_.baz" & @CRLF & _
".bar" & @CRLF & _
"baz_" & @CRLF & _
"._" & @CRLF & _
"-" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")