$re = '/^(?=.{1,50}$)[a-z\d]+(?:[._-][a-z\d]+)*$/m';
$str = 'a
ab
foo
foo_123_bar
123foobarbaz123foobarbaz123foobarbaz123foobarbaz1
123foobarbaz123foobarbaz123foobarbaz123foobarbaz12
123foobarbaz123foobarbaz123foobarbaz123foobarbaz123
foo_bar_.baz
.bar
baz_
._
-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);