#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=00_000_A\.B\.C\._One_Room)(?:\r?\n[A-Za-z]+_[A-Za-z]+)+"
Local $sString = "00_000_A.B.C._One_Room" & @CRLF & _
"Schrute_Dwight" & @CRLF & _
"Halpert_Jim" & @CRLF & _
"Scott_Michael" & @CRLF & _
"00_000_A.B.C._One_Room" & @CRLF & _
"Schrute_Dwight" & @CRLF & _
"Halpert_Jim" & @CRLF & _
"Scott_Michael" & @CRLF & _
"01_200_A.B.C._Two_Room" & @CRLF & _
"Schrute_Dwight" & @CRLF & _
"Halpert_Jim" & @CRLF & _
"Scott_Michael"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")