import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=00_000_A\\.B\\.C\\._One_Room)(?:\\r?\\n[A-Za-z]+_[A-Za-z]+)+";
final String string = "00_000_A.B.C._One_Room\n"
+ "Schrute_Dwight\n"
+ "Halpert_Jim\n"
+ "Scott_Michael\n"
+ "00_000_A.B.C._One_Room\n"
+ "Schrute_Dwight\n"
+ "Halpert_Jim\n"
+ "Scott_Michael\n"
+ "01_200_A.B.C._Two_Room\n"
+ "Schrute_Dwight\n"
+ "Halpert_Jim\n"
+ "Scott_Michael";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}