package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[Ff]loor\s+[Aa]rea:?\s+(\d{1,4})`)
var str = `"A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift"
"Newbuild flat. Floor Area: 30 sq.m"
"6 bed house with floor area 50 sqm, lot area 25 sqm"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}