// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[Ff]loor\s+[Aa]rea:?\s+(\d{1,4})").unwrap();
let string = "\"A beautiful flat on the 3rd floor with floor area: 50 sqm and a lift\"
\"Newbuild flat. Floor Area: 30 sq.m\"
\"6 bed house with floor area 50 sqm, lot area 25 sqm\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}